ConfigMgr Error Object: instance of SMS_ExtendedStatus


Whilst attempting to edit a task sequence after a SCCM 2012 R2 in place upgrade, I came across the following error and was unable to proceed any further.

ConfigMgr Error Object:Instance of SMS_ExtendedStatus{

Description = ‘Failed to load class properties and qualifiers

For class BDD_UsePackage in task sequence.”;

ErrorCode = 2147749890;

File =

“e:\\qfe\\nts\\sms\\siteserver\\sdk_provider\\smsprov\\ssptspackage.c

pp”;

Line = 3454;

Operation = “ExecMethod”;

ParameterInfo = “SMS_TaskSequencePackage”;

ProviderName = “WinMgmt”;

StatusCode = 2147749889;

};

 

SMSExtended01

Basically MDT 2013 had been installed but had not been integrated into ConfigMgr.

So the following steps were undertaken to fix.

Click the Start Menu and choose Microsoft Deployment Toolkit>Configure ConfigMgr Integration.

When prompted remove the existing MDT extensions. Click Next.

MDT01

Click Finish when complete.

MDT02

Then head back to the Start Menu and run the ConfigMgr Integration again.

This time install all the MDT extensions including Task Sequence actions. Click Next.

MDT03

Click Finish when complete.

MDT04

 

39 comments

  1. Hi,

    These errors have just appeared when attempting to edit task sequences – however, we have not upgraded the site – so not sure what caused this. Would you think it is still OK to remove and re-add the MDT 2013 extensions? Thanks

    1. Hi Paul,

      Still issues I am afraid – “Failed to call SMS_TaskSequence::LoadFromXml due to error 80041013”.

      I have not bounced the primary or restarted any services (yet).

      Thanks

      1. Hi Paul – no luck with this I am afraid. Services, then Server restarted, however, now we have issues connecting to the site database (on the same server). A few of the SMS services have not restarted successfully after the restart (SMS_Exec, SMS_Site_Backup etc). It looks like the SQL connectivity has been lost – do you have any thoughts on what could be the cause? Thanks

  2. Hi Paul, yes restarted the primary site server this morning. SQL is local to the server. SQL team have had a look at DB appears OK – the SMS Exec service stopped last night at 2am. When I came in this morning, component statuses for the MP on the Primary was not working.

  3. Ran ‘Configure ConfigMgr Integration’ tool as administrator to remove existing MDT extensions and got this when I tried to proceed:

    Unable to remove binaries: System.UnauthorizedAccessException: Access to the path ‘C:\Program Files (x86)\Microsoft Configuration Manager\AdminConsole\Bin\Microsoft.BDD.CM12Actions.dll’ is denied.
    at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
    at System.IO.File.InternalDelete(String path, Boolean checkHost)
    at Microsoft.BDD.Wizards.SCCM_ConfigureRemove.RemoveCM12ConsoleExtensions(StringBuilder& output, Int32& errorCount, Int32& warningCount)
    Removed extension files from C:\Program Files (x86)\Microsoft Configuration Manager\AdminConsole\\XmlStorage\Extensions

    Operation completed with warnings or errors. Please review the output above.

  4. Hello Admin, I am getting Configmgr Error with Description = ” The XML content is invalid; check that the XML matches the schema for the SMS task sequence”; ErrorCode = 3222070536.

    I am getting the same error while editing or exporting the TS. I am able to working normally with other TS. Did Primary server reboot but the error remain same.

    Do you have any suggestions for me ?

  5. Getting this error after following the steps.
    Failed to load class properties and qualifiers for class BDD_UsePackage in task sequence. 0x80041002 (2147749890)

  6. I’m on 2006, had this problem from time to time since 1902 I think. Everything work and bam,oh, where you editing the same task sequence 2 minutes ago? Well now, I’m now working anymore. But my headache is that sometime, like right now, it just won’T work! Tried removing, adding mdt again, running console and extension as admin, reseting computer, reseting servers, reinstall mdt on server, nothing work, I’m stuck with this error and I repeat the error anywhere I try it, not just on my computer…. This need to be fix by Microsoft asap…

Leave a Reply to James Cancel reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google photo

You are commenting using your Google account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s